1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

zend, setup and xampp 1.4.15

Discussion in 'Installation / Upgrade Questions' started by djemberay, Sep 22, 2005.

Thread Status:
Not open for further replies.
  1. Greetings,

    I have xampp on an XP machine with Mambo. Works great and have done lots of dev on it. I simply uncommented some lines in the php.ini to enable ZEND and tested by running PHPINFO. It shows up as installed.

    Problem: When I browse to index.php the setup directory I get a page telling me the Zend Optimizer is not installed. I'm one that normally figures out problems myself through forums etc., but I've tried everything and am flummoxed! I really want to use this program as it blows away all the free ones I've looked at. Any tests or suggestions to help me narrow this down? HELP!

    kind regards,

    -raymond
  2. ve9gra

    ve9gra Support Team

    You can try downloading the tester script to confirm that your version of Zend meets the requirements of EPC. I think that xampp will let you use the ionCube version if Zend doesn't work.
  3. Brian

    Brian EPC Developer Staff Member

    You may need to restart the server to initialize Zend?

    Had to do that with WAMP (which I use to debug locally).
  4. tester looks good, but setup won't run...

    Brian and Gervais,

    Thanks for the replies. I ran the tester and everything passes but IONcube. This is fine becuase I'm using Zend I think. I also restarted the server multiple times (just to make sure). Let me run this by you. Here are the lines in the PHP file. Can anyone see any issues with them? Are their lines missing?

    [Zend]
    zend_extension_ts = "\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
    zend_extension_manager.optimizer_ts = "\xampp\php\zendOptimizer\lib\Optimizer"
    zend_optimizer.enable_loader = 0
    zend_optimizer.optimization_level=15
    ;zend_optimizer.license_path =

    I noticed that the license line is commented out and I've attempted to put the full path (adding a "c:") to the two file specs above with no avail. Anything else that might be wrong above?

    kind regards,

    -raymond
  5. Never mind!

    I had to set the loader line to "1" in the PHP.INI file.

    Thanks for the help!

    regards,

    -raymond
Thread Status:
Not open for further replies.

Share This Page