1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

WP sidebar integration

Discussion in 'Wordpress' started by elmalako, Aug 12, 2008.

Thread Status:
Not open for further replies.
  1. Hi folks, really hope you can help me here.....

    I was finally able to activate the calendar as a plugin in wordpress.....and now I've got the calendar displaying at the top of every screen, and also results in this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/<snip>/html/GS/wp-content/plugins/calendar/functions/dateMarking.php:207) in /home/content/<snip>/html/GS/wp-login.php on line 214

    In addition, I can't get it to integrate into the sidebar. Trying to add the php require statement(s) results in an error -- I'm obviously not specifying the correct location of the calendar.php file. (I'm modifying the sidebar.php within the theme I'm using (a subdirectory of the themes folder of wp-content). The calendar was installed into the plugins folder of wp-content. Although I've tried every iteration I can think of, I believe the path should be "../../plugins/calendar/calendar.php")

    As a side note, I found that I had to change the commented section at the top of the calendar.php file in order for WP to recognize it as a plugin. Is it possible that the comment format of the other files is causing them to be unread by WP???

    Thanks very much for any guidance, I've been banging my head against this for close to a week now. Very tired and sore, but determined to get this working!

    -E




    Can you please help me???
  2. ve9gra

    ve9gra Support Team

    I think you misunderstood the instructions. I guess they're not really specific on what needs to be done. The WP plugin is the only thing that should be uploaded to /wp-content/plugins/.

    The calendar should be installed to your html root directly. You should end up with /home/content/<snip>/html/calendar/.

    By installing it at that location, you should be able to use the plugin without any modifications. Once you fix that, see if that doesn't also solve your issue with the Warning error. If it doesn't please provide a URL to your installation.
  3. Brian,

    Thanks, that was great clarification. I thought I needed to install the calendar into the wordpress installation but I was mistaken.

    I'm not done, yet, though <g>!

    I've got the calendar displaying in the sidebar where I want it, but there's no styling. When I change to TOC, the list displays with formatting, but when I switch back, the formatting disappears. The url is: montgomerygirlscouts at gmail dot org. Help, please?!?
  4. ve9gra

    ve9gra Support Team

    You need to make sure to add the $CSS line in your header.php file in your WP theme.
  5. Yes, I did that in the header file. And the calendar shows up where I expect it to in the sidebar.

    When I set a $var=1 I get formatting. When I don't set the variable (ie, leave the default setting), I get no formatting of the calendar itself. Only an event gets styled.

    Any ideas?
  6. ve9gra

    ve9gra Support Team

    You really need to read how to integrate the calendar in WP again... Or maybe I should create a tutorial.

    You need the $CSS line in the header.php file. Then you need the $OL line just inside of the <body> tag (which is more than likely also in header.php, but that depends on your theme). Then in the sidebar.php, that's where you'll finally add the calendar.

    The $CSS line:
    PHP:
    <?php $CSS=1; require("calendar/calendar.php"); ?>
    The $OL line:
    PHP:
    <?php $OL=1; require("calendar/calendar.php"); ?>
    The calendar line:
    PHP:
    <?php require("calendar/calendar.php"); ?>
    You NEED to have those three requires... having only one does not work.
  7. Gervais,
    I apologize if I wasn't clear in my last post.
    I *have* those three requires, *exactly* as you show (but pointing to the proper directory).
    Nonetheless, the css file is not being applied to the calendar. There is no styling whatsoever.
    Maybe I need the next page in your tutorial <g>.
    Thanks!
  8. ve9gra

    ve9gra Support Team

    From cheking your website, the calendar is not installed in /calendar. If you check the generated source (right click - view source in your browser), you'll see that the CSS is expecting your install to be in /calendar.

    If you've moved your installation, make sure your /calendar/calendar.php file is world writable and login to your Setup Manager. It should update the paths automatically. Should that not work, edit your $urlPath in that file to match your installation.
Thread Status:
Not open for further replies.

Share This Page