1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

Will not connect after switch to MySQL5/socket

Discussion in 'Installation / Upgrade Questions' started by clausiam, Feb 4, 2011.

Thread Status:
Not open for further replies.
  1. I upgraded to MySql 5 since my host is discontinuing MySql 4.
    The old host string for v4 was just "localhost", but for v5 they have a socket parameter too (/tmp/mysql5.sock). In my own php apps I just give hostname as "localhost:/tmp/mysql5.sock" but when I use that as the $sqlHost in the config.inc.php I get an "Invalid Access - 19" error - indicating it cannot connect.

    If the host:socket is not supported in EPC how do I go about connecting to a db that uses a special socket parameter?
  2. Brian

    Brian EPC Developer Staff Member

    Try manually editing the config.inc.php file and insert the parameters there. It may be the encoding of the Setup Manager writing the parameters and HTML entities instead of the actual characters.
Thread Status:
Not open for further replies.

Share This Page