1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

What are you going to do about the new PHP server updates?

Discussion in 'Installation / Upgrade Questions' started by Fasteddys, Jun 4, 2011.

Thread Status:
Not open for further replies.
  1. My webserver service updated to a new version of PHP and it has caused me great problems with your calendar program for WordPress. It continually throws this error

    Fatal error: Incompatible file format: The encoded file has format major ID 2, whereas the Loader expects 4 in /home/fastesev/public_html/calendar/events/index.php on line 0

    I am not sophisticated in how to fix this. Seeing I paid money for your calendar, you need to address this issue immediately. My client is not happy that his calendar is not working right in the middle of their 15th anniversary celebration. I need to get this fixed NOW and have no idea how to do it.

    Please help ASAP!
  2. Brian

    Brian EPC Developer Staff Member

    It's quite simple. Just update the calendar to the files that are compatible with your server.

    1) Run the tester script from our Free Download page and download the compatible files.

    2) Follow the upgrade section of the instructions (link below).
  3. Thanks for your quick reply

    I am not sure which upgrade is needed? I run the test script and then that will tell me what version of the calendar I sould download and upgrade to? Is there some sort of binary upload needed for this script? This calendar worked flawlessly for several years and then just broke on the new PHO upgrade. I will try the script
  4. OK, I ran the calendar script tester and it has identified my problem as being that Zend loader does not work with my server. It suggests ioncube. I ran the ioncube script tester and it says that my server has ioncube 3.2 installed, but the calendar needs 4.1 or higher. Will the calendar run on 3.2? If so how do I get it from Zend to Ioncube?
  5. Brian

    Brian EPC Developer Staff Member

    You can get it for free from www.ioncube.com/loaders (there should be a direct link in the ionCube test results page too).
Thread Status:
Not open for further replies.

Share This Page