1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

Trial Version - Limit on Number of Events?

Discussion in 'General' started by nottrixie, Mar 20, 2005.

Thread Status:
Not open for further replies.
  1. I'm having a problem with the trial version of the calendar program. Everything seemed to be working just fine, but after submitting an event, the program locked up and wouldn't return to the "enter an event" page. This was around the 12th one that I entered and I don't believe I did anything different than the others to cause this error. I tried closing the window and starting over, but now after entering my user name and password, I get a "can not find server" page. Does this mean I hit a wall on the number of entries or did something get corrupted? I can still view the calendar so that part is still working. It's just the screen to enter events that seems to be having a problem.
  2. Brian

    Brian EPC Developer Staff Member

    There is no limit in the trial for the number of events. What type of database were you using?
  3. I am using the flat-file. I am able to set up a mySQL database if that works better.
  4. Just to test it, I deleted the flat-file database and built one with mySQL. For some reason it also stopped working after the 12th entry. Any ideas?
  5. Brian

    Brian EPC Developer Staff Member

    Is the 12th entry this time the same as the 12th entry when using the flat-file?
  6. I think I may have figured it out. It was nearly the same entry as before, but after a bit of experimentation it seems to be certain date ranges that are having the problem. So far it appears that the stoppage happens anytime I try to do an entry between April 10th to the 30th and seemingly any time in February. If I do an entry during those times the program gets stuck after I hit the "save event" button and won't return to the "add event" page. If I go into the database and delete the entry, the program works again. My guess is that one of the files that has to do with the date ranges is corrupted in some way. If you think that is the case, which ones should I replace?

    Thanks!
  7. Brian

    Brian EPC Developer Staff Member

    If you try the same events on the Online Demonstration on this web site, does it work?

    The files you need to re-upload would be all in the events and functions directories.
  8. I added the dates in February and April on the demo and it worked just fine. I tried replacing the function and events files and it is still happening. Other than starting over completely with a fresh upload, do you have any other hints?
  9. Brian

    Brian EPC Developer Staff Member

    Did you change any options (like the date format) before adding events?

    I would try uploading all of the files (except the main license.php file) and see if that helps. If not and your server is compatible with the other version, I would give that a try.
  10. I did change the date format, but that didn't seem to be the problem. I replaced all the files except the license like you instructed and now the problem seems to trace back to the "overlib" function. When I turn that on it seems to work fine when viewing the calendar, but when I try to access the "events" screen that is when it stops working. If I go back into setup and turn off "overlib", I have access to the events page again. Hmmm... I like this calendar and hope I can get it to work at some point.
  11. Brian

    Brian EPC Developer Staff Member

    I have a registered user who has a very similar problem. With overlib turned off, the editor works as expected. But with it on, it locks up.

    I'm looking into this as there isn't anything obviously wrong, but it may have something to do with the particular configuration of the web server.

    Can you tell me the web server and version, php version, etc that's on your server?

    In the mean time, you could use the script with just the on-click pop-ups instead of the on-mouseover pop-ups until this is resolved.
  12. Here's the scoop from my hosting company: superbhosting.net

    The server is currently running 4.3.8 . For a comprehensive list of the modules compiled into php, please go here :
    http://207.228.243.232/superb.php

    I'm running the current trial version of the calendar.
  13. I'm seeing basically the same thing.

    I'm running the trial version of 6.03 (my order is pending) with mySQL 4.0.18. A link to phpinfo() on my site will be sent to you, Brian, via PM, along with access to see what's going on and the SQL insert statement for the offending event.

    When I added the event this morning, it went to the page that says the database has been updated, like it should. It then meta-refreshed to a zero sized reply error page. At this point, trying to go to any page within the events admin results in zero sized reply. The setup admin and the main escal/ script are unaffected.

    At first I thought it was somehow due to the phpsessid, because I could get the login page back up by deleting the cookie. Once the cookie is set again, zero-sized reply again. However, I then found this thread and tried deleting the newly added event using phpmyadmin. Voila! I was able to administer my events again. I then re-added the event, and was faced with zero-sized replies.

    The event date was for Feb 7, 2005.

    Oh, FWIW, I have only 6 events, plus the offending event. The offending event currently has an id of 12. Changing that id to 5 (no other event has that id) does not affect the problem.
    Last edited: Mar 31, 2005
  14. Brian

    Brian EPC Developer Staff Member

    Responded to your PM. I think I have a fix for this...
  15. Me, or nottrixie? I haven't received a PM..
  16. Brian

    Brian EPC Developer Staff Member

    I'm working on a fix as we speak (err, type). I hope to have it released in the next day or two. If you want to test this, please PM me your email address and which version (Zend or ionCube) and I'll send you the updated files.
  17. OK - Same problem

    I can edit events but cannot add them. The install worked until Feb.

    I am new to the company and have been just been given the task of "Fix this site"

    What do I need to provide you in order to get help?
    What is the process to upgrade the version?
    I was told that when they installed the current version they have they had to hack it to change all of the ".php" files to ".php4" in order for it to work on the server I can write a small perl script to do this same fix if need be.
  18. Brian

    Brian EPC Developer Staff Member

    What version are you using and can you provide a link to the web site or send me PM with your event manager login information.

    [Please start a new thread as the issue is unrelated to the posts above it.].

Thread Status:
Not open for further replies.

Share This Page