1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

Problems After Upgrade - Can't Add Events

Discussion in 'Installation / Upgrade Questions' started by RudyG, Apr 17, 2009.

Thread Status:
Not open for further replies.
  1. RudyG

    RudyG New Member

    Recently, PHP and Zend were updated on my server. After the upgrade I was unable to add new events - but could see old ones.

    Whenever trying to add a new event the process appeared to go through without any problems or errors - even the script even responded with something like "Database has been uodated". But the new event does not show in the Calendar, nor are there any new entries in the database itself.

    I just took the additional step of Upgrading the script to the latest version. Same problem as before - still can't add new events - and I'm not getting any errors...

    Help...
     
  2. Brian

    Brian EPC Developer Staff Member

    Are you using mySQL? If so, do you have a repeat or repeatx column in the database table?
     
  3. RudyG

    RudyG New Member

    Brian,

    Yes, I'm using MySQL, and yes, I have a field named "repeatx".

    -Rudy
     
  4. Brian

    Brian EPC Developer Staff Member

    It seems you database did update correctly... Try upload all of the files in the events directory again. You may have an issue with one or more of them.
     
  5. RudyG

    RudyG New Member

    Brian,

    I uploaded the event directory. Still not working.

    -Rudy
     
  6. ve9gra

    ve9gra Support Team

    He didn't specify, but make sure that you upload those files in forced Binary mode. Using anythign else will break the encryption and render them useless.
     
  7. RudyG

    RudyG New Member

    Thanks for the reply. Tried that, no help.

    Please correct me if I'm wrong, but it seems that if the file upload type corrupted the Event files, then the script would not function at all. The script appears to function, but the event does not get inserted into the database... No errors...
     
  8. Brian

    Brian EPC Developer Staff Member

    Can you open a support ticket and attach a dump of your database?
     
  9. RudyG

    RudyG New Member

    Brian,

    I've solved the problem by doing a complete, clean reinstall of your script - including the database structure.

    When I first encountered this problem, I did a complete reinstall using your "auto installer", BUT I kept using the existing database. The problem persisted... This obviously points to a problem with the database.

    Here is my opinion on what caused this... A few months ago, I moved that site to a new server using the Plesk Migration tool. I've noticed problems with databases after migration using Plesk. I've been doing dumps and recreating databases manually on the new server to resolve this. It's probable I skipped this step with this web site's database... And since the client has rarely used the site, or added many events, the problem did not become evident until an unrelated Zend issue caused the client to notice the calendar was not working...

    I will open a support ticket and send you the bad database - in case it will help someone else in the future, but my problem is solved and does not require additional support.

    Thank you for your prompt responses...

    -Rudy
     
Thread Status:
Not open for further replies.

Share This Page