1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

MySQL selected but still using flat-file?

Discussion in 'General Support' started by straw-man, Jun 30, 2005.

Thread Status:
Not open for further replies.
  1. In my preferences I have my calendar configured to use a MySQL database. The connection is working and the calendar displays the one event that is listed in my MySQL database.

    When I try to add an event, I get a permission denied error trying to open the esdates.txt file in the /database directory. If I change the permissions on that file and the database directory it 'works' and allows it to add items to the calendar, but they are added to the flat-file db not the MySQL db (so they are not displayed on the calendar).

    Has anyone had this problem? I originally had it with (I believe) version 6.1.5. I have since upgraded the the latest 6.2.4 IonCube version and I'm still getting the error.

    In my setup manager, I have verified that flat file is turned off and MySQL is turned on. I've tried to toggle them as well...turn db off and flat file on then reverse it, with the same result.

    Any ideas?

    Thanks!

    Straw-man
  2. ve9gra

    ve9gra Support Team

    Have you tried having both enabled and then choosing which database to edit when logging on to the Event Manager?
  3. if both are selected, it still uses flat-file. With both selected, it does show the records both from the db and the flat-file. When new records are saved, they are saved to file.

    I don't see a place when saving an event to save it to the database instead.
  4. duh - possible solution?

    One thing that JUST hit me....

    you said 'when you log in' select the mode....

    I am passing the username/password variables via the URL to log in automatically from my administration site. I'm assuming that is my problem...is there a way I can be sure it passes to the MySQL database from the URL path?
  5. ve9gra

    ve9gra Support Team

    Yes!! That will make a difference... According to this post from Brian you have to add to that command line
    HTML:
    &dataMode=s
    's' being for MySQL mode, and 'f' for the Flat-file.

    I've tried it just now, and I'm not 100% sure it works. I'll do more testing.
  6. doh!

    I just looked at my link and I had dataMode=f in there....problem solved! Thanks a bunch.
Thread Status:
Not open for further replies.

Share This Page