1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

Multi Calendar not working properly

Discussion in 'General Support' started by champi0n, Dec 20, 2007.

Thread Status:
Not open for further replies.
  1. champi0n

    champi0n New Member

    I've installed the calendar and included it on a page called events.php

    Using the BLOG display, everything works fine and as expected, but I want to use the blog display + multi (Showing 3 months in calendar view - with the selected days events in the list)

    But once i use the code (from the documentation) for MULTI=1, everything looks fine until i click something.

    Clicking a day (any day) in any month brings me to index.php (umm why?) So ok... added unset($epcAltLink); $epcAltLink="events.php";
    And now i click a day and it keeps me on the events page, but it doesnt display the day clicked, just the month.

    And when clicking on the 3rd month, it now brings up the next 3 months (When i have put in $noNav=1) So when clicking in Feb on any day, it now shows me feb, mar, april... why?

    All i want (and its quite simple) is to display 3 months - with the first month being now. And when i click on a day, it displays that days events in my list (as how the blog example works) and doesn't navigate away from the 3 months displayed!

    So in other words - the BLOG example with the list under 3 static calendars starting with the current month.
     
  2. Brian

    Brian EPC Developer Staff Member

    Can you provide a link to your page?
     
  3. champi0n

    champi0n New Member

    I was going to PM, but no PM button?

    anyways in the meantime the problem is described above and the code used is the following:

    PHP:
    <?php $CSS=1; require ("calendar/calendar.php"); ?>

    <?php
    /*
    $MULTI=1; 
    $epcMultiWidth = "600px";
    $epcMultiPad = 10;
    $epcMultiNav = "580px";
    $epcMultiCol = 3;
    $epcMultiRow = 1;
    $epcMultiAdv = 0;
    */

    #unset($epcAltLink); $epcAltLink="events.php";
    $EPCBLOG=1;
    $noNav=1;
    require (
    "calendar/calendar.php"); 
    ?><br/><br/><?
    $EPCBLOG
    =2;
    $template="blog.php";
    $DF "l, F j, Y"
    require(
    "calendar/calendar.php"); 
    ?>
    Either way it goes, it seems like the multi wants to add a new event when i click? (by going back to index with a sessid?) its a default install, but the current uncommented code works as expected, but i want the multi calendar (3 months view)
     
  4. Brian

    Brian EPC Developer Staff Member

    Can you not provide a link?

    Make sure you're not logged into the Setup Manager when viewing the regular page. You're server/computer may carry over the login credentials...
     
  5. ve9gra

    ve9gra Support Team

    To have the multi calendar working with the Blog mode, there are some modifications required. I can't seem to find a post relating to that, but I was certain that I had posted that info before.

    It might be in an email to a client... Let me do a search, I'll get back to ya.
     
  6. ve9gra

    ve9gra Support Team

    Ha! I knew I posted this before...

    Multiple Calendar Blog?

    Just make sure to adjust the line numbers to the current version as this was coded a year ago.
     
Thread Status:
Not open for further replies.

Share This Page