1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

Does not display correctly after integration

Discussion in 'Installation / Upgrade Questions' started by bruno71, Dec 19, 2005.

Thread Status:
Not open for further replies.
  1. bruno71

    bruno71 New Member

    I recently installed the trial version of EPC to try out for our local company Intranet. Everything went smoothly and I was able to integrate it with our Intranet web site. However, when I changed it to "Text on Calendar" mode, I noticed that none of the formating and display options took effect. The only thing that displays is the green highlight on Christmas (I added one holiday event). Everything else is just plain text...no background colors, cell formating, etc. It is almost as if it was missing the CSS file, but I added the reference to it just as the instructions said. Any ideas? Thanks for the help.

    ~bruno71
     
  2. Brian

    Brian EPC Developer Staff Member

    It's definitely a CSS issue. Check the HTML source of the rendered page and see if you find the esstyle.css reference and that the path is correct.
     
  3. bruno71

    bruno71 New Member

    This is the reference line in the PHP file...
    <?php $CSS=1; require("calendar/calendar.php"); ?>

    This is the code that shows up in the rendered HTML page...
    <link href="/calendar/theme/default/esstyle.css" rel="stylesheet" type="text/css"/>
    <style type="text/css">
    <!--
    .s22 {background-color: #A4CAE6;}
    .s21 {background-color: #F2BFBF;}
    .s23 {background-color: #CCFF00;}
    .s24 {background-color: #FBF484;}
    .s29999 {background-color: #FFC18A;}
    -->
    </style>



    All the code looks OK, but it still wasn't working. Just for fun, I replaced the reference line in the PHP file with this...
    <link rel="stylesheet" type="text/css" href="calendar/theme/default/esstyle.css">

    After that, the calendar displayed correctly. The problem was that, in the calendar.php file, I had the variable $urlPath set to "/calendar/". I changed it to "calendar/" and changed back to the original PHP reference line. Now the calendar displays just like it should...

    However...when I try to go back into the Setup Manager, it tells me that the $urlPath variable is not set. How do I work around this?

    ~bruno71
     
    Last edited: Dec 19, 2005
  4. Brian

    Brian EPC Developer Staff Member

    Load the file calendar/calendar.php in your browser (it will not appear correctly).

    Copy the complete address from the address bar to calendar.php and the urlPath.
     
  5. bruno71

    bruno71 New Member

    Thanks Brian! That worked.
    By the way, I just finished ordering the full version of EPC. This is going to make updating and maintaining our company calendar so much eaiser. Thanks for a great product!

    ~bruno71
     
Thread Status:
Not open for further replies.

Share This Page