1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. To combat forum spam, new accounts will need to make at least one (valid) post.
    Otherwise, we will periodically purge all users without posts or that haven't confirmed their account.

Bug in the tester script

Discussion in 'General Support' started by keithlee, May 21, 2005.

Thread Status:
Not open for further replies.
  1. Greetings,

    I've just installed Fedora 3 and began my installation of Easy Calendar. Once I downloaded the tester script, I realized that I needed to install the Zend Optimizer. Well, after I successfully install the Zend Optimizer (checked it with phpinfo), the tester script still complained about an incompatible version. I found the culprit to be a small the version numbers being interpreted improperly when being converted to ints for numerical comparison. I've added this line to the script to fix the problem:

    $version = str_replace(".","",$version);

    It simply removes the . inbetween the major.minor.revision numbers.

    My initial comparison was of the numbers: 2.5.5 (the minimun version) and 2.5.10 (my currently installed version). The original script found that 2.5.5 is greater that 2.5.10 which ( became 2.5.1).

    I hope this correct.

    --Keith Lee
  2. Brian

    Brian EPC Developer Staff Member

    Thanks for pointing this out. This has been fixed and is in the current tester download.
Thread Status:
Not open for further replies.

Share This Page